View unanswered posts | View active topics It is currently Sat Jun 24, 2017 11:32 pm



Reply to topic  [ 14 posts ]  Go to page 1, 2  Next
 MSD Power Grid Truble 
Author Message

Joined: Fri May 20, 2016 5:18 am
Posts: 105
I friend of me her in Sweden has put on a new MSD Grid with new coil, distributor "crab cap" and plug wires and the car runs like crap.
The nr: 7 cylinder spark plug shows not a single carbon atom on it ( no firing) look like brand knew out of the box but wet with gas.
The other plugs have significant carbon build ups .
They have gon thru the wiring rooting, ground connections, wire connections and so on several times and software upgrading knew logging
trying to run it simple as possible with out all features rew limits to stepper and so on
Looked in to 5 to 7 cylind induction misfire as well , and found nothing so far.
i looked at the car yesterday at the local track and we took of nr 7 plug wire from the plug and hooked up a plug grounded with a
jumper cable fired the engine up and had a spark at the plug hmmmm. the color of the spark yellow/ orange did not impress me very much
I knew that those digital programmable MSD the systems can be very sensitive to al kinds of "disturb ens"
My thinking is that he got a bad unit, anyway is there someone that have had a similar experience or even heard of something like this .
And by the way he checked the engine ( cylinder leek down, valve springs,valve clear ens and so on ) NOTHING
Tobbemek . Sweden


Thu Aug 18, 2016 2:41 am
Profile
Site Admin

Joined: Fri Feb 08, 2013 2:37 pm
Posts: 1701
Did you try swapping the wire with another cylinder? You sure it isn't a 4-7 swap camshaft?


Thu Aug 18, 2016 9:29 pm
Profile

Joined: Fri May 20, 2016 5:18 am
Posts: 105
Hello Tuner. Yes he did all the basic "roulout "swapped plug wires changed plugs.
He had a MSD 7 digital unit on it before and wanted to go with the new grid system, to
be able to make track tuning to the car, nothing ells was don to the engin.
New progrid system, new pro HVC ciol new MSD dist and crank trigger.
Fires right up, drives down to the track to find out it went 2 tents slower.
Check spark plugs and find nr 7 whit out any carbon build up looks like right out of the box but wet with fuel.
Put on a new sparkplug same thing not a singel carbon atom on it .Swapped wires between 5 and 7 cylinder, same thing
plug looks bran new like never fired. Pulled the nr 7 plug wire put on a plug grounded with a jumping cable, fires up
and it has a yellow/orange spark 8) hmmmm. I figure the plug dos not light under cylinder pressure.


Fri Aug 19, 2016 3:07 am
Profile
Site Admin
User avatar

Joined: Fri Feb 08, 2013 5:50 pm
Posts: 2302
Swap the distributor out. May be something with the crab cap or in the distributor.


Fri Aug 19, 2016 9:19 am
Profile

Joined: Fri May 20, 2016 5:18 am
Posts: 105
There is no electronic parts in side the Dis,t every thing mechanical looks fine, rotor facing checked twice, isn't a crab cap that was wrong of me, its a wide typ.
Anyway they have checked the cap with magnify glass ohm tested al cap connections and find nothing wrong with the Dist,rotor ore cap.


Fri Aug 19, 2016 2:19 pm
Profile

Joined: Fri May 20, 2016 5:18 am
Posts: 105
There is no electronics in side Dist. mechanical it looks fine, rotor facing checked twice.
Cap and rotor checked with magnify glass, cap connections ohm tested and everything looks fine.


Fri Aug 19, 2016 2:29 pm
Profile
Site Admin

Joined: Fri Feb 08, 2013 2:37 pm
Posts: 1701
Run it in total darkness to see if any electrons are running wild, off the reservation.


Fri Aug 19, 2016 11:22 pm
Profile

Joined: Fri May 20, 2016 5:18 am
Posts: 105
Yes Tuner. thought of that to, have dun that a couple of times whit standard cars looks really pretty som times :D
I dont trust this digital computerized stuff especially well.
Still think there is something wrong with the digital electronic stuff.
The system should be able to control individual cylinder timing on demands right, and in my world something electronical that should controll
can be out of order.


Fri Aug 19, 2016 11:54 pm
Profile
Site Admin

Joined: Fri Feb 08, 2013 2:37 pm
Posts: 1701
Does it have the spark plug wire sync kit connected to #1 plug wire and individual cylinder control activated in the software? Is the correct firing order and number of cylinders entered in the software? Move the plug wire sensor to another cylinder and see if the misfire moves to another cylinder also.


Sat Aug 20, 2016 1:39 am
Profile

Joined: Fri May 20, 2016 5:18 am
Posts: 105
No, all extra "vaganca" features was never connected, downloaded ,demand or whatever, just started as plain an simple as possible
to begin with, and learning from there. Its my Hemi Cuda buddy that "plays " the keyboard he is still young in the neighborhood of 50 , i spent
4-5 ours reading to keep up but gave up considering it will take me just to much effort and time att the moment, still have to sleep some times
and make a " tener , buck, dinero" or in what part of the world you lives in now and then. Maybe when i get my pension if the state still have anything leftovers for the seniors. posting.php?mode=reply&f=21&t=1250#


Sat Aug 20, 2016 4:57 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 14 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.